DccPgm2 Decoder Management Software

USB接続（BUSPOWER)デコーダプログラマ

簡易コマンドステーション

簡易PWM式DCパワーユニット

MANUAL v1.0　2006/01/20

概要、仕様

使用上の注意とトラブル対処

導入（インストレーション）

チュートリアル


DccPgm2 概要

概要、仕様

1. 概要

DccPgm2は、DP１と共に使用する、ソフトウエアです。

Windowsによる、GUIによって、今まで面倒であった、DCCデコーダの設定を飛躍的に簡単にします。

DirectMode + BitModeの利用により、全CV値の読み出しが、フル装備のデコーダでも、１分あまりで完了します。このモードを使っていない
システムでは、１０～２０倍、時間が余計に掛かります。

また、デコーダの設定と試験運転を同時に行うことにより、デコーダの能力を１００％引き出すことが可能です。

2. 仕様

項目 |  | 内容
CVプログラミング機能 |  | Paged Mode Direct Mode (bit mode含む) OPSモード
動作電圧 | BUSパワー時 | 5V 500mA
 | 外部電源 | 9-18V 定格1A （逆接続保護） 2.1mm センタープラス DCプラグ
出力 | BUSパワー時 | 約+-12V 100mA 出力遮断回路あり
 | 外部電源 | 9-18V 定格1A 出力遮断回路あり
USBインターフェース |  | USB1.1 BUS Power MAX 500mA
簡易コマンドステーション |  | 車載デコーダ 28,128ステップモード 5列車まで同時管理 ファンクション 1-12 アクセサリーデコーダ 1-999アドレスまで
簡易DCパワーユニット |  | PWM (30Hz-800Hz)
PCプラットホーム |  | Windows98/2000/XP
外形寸法 |  | 56*66*21mm
付属品 |  | 専用接続ケーブル ミニCD （USBドライバ、ソフトウエア） USB接続ケーブル １２V 1A DCアダプタ（2.1mm センタープラス ）


DccPgm2 注意

使用上の注意とトラブル対処 更新2006/01/19

１．取り扱い

  • DP1において、USBケーブルの抜き差し、ならびに、DCアダプタの取り外しの際は必ず、DccPgm1を終了したで、
    行ってください、ハングアップ等のトラブルの原因となります。
  • ハングアップしたりアプリケーションが異常終了した場合には、DccPgm1を終了の上、USBケーブルの再接続を行ってください。DP１にはリセットボタンはついておりません。

２．USB電力について

  • DP1は、DCC信号を送出するために、最大500mAの電力供給を要求します。
  • 特に、瞬間的に最大電流まで達するために、電源の弱いPCを使用している場合、あるいは
  • USBハブを経由して使用している場合には、急激な電力要求に耐えられずに、パソコンと共にハングアップするケースがあります。
  • 逆に、デコーダ設定時に、最大電流を要求するのは極わずかな時間(10mSec以内）なので、明らかに電源能力オーバーなのに問題なく動作することもありますが、上記のことを十分留意してご使用ください。
  • 十分に容量のある、外部電源を接続している場合でも、DCCに接続しているモータからのサージ電流により、ハングアップするケースもまれにあります。
  • 内部的には、電源のフィルタリングとサージ対策はしておりますが、完全に絶縁しているわけではないので注意してください。

３．電磁波対策について

  • DP1はUSBを使ったコンピュータ機器ですので、強い電磁波（ADSLモデム程度）が内部で発生しています。
  • DP1専用ケーブルに取り付けられている、”フェライトコア”と呼ばれるものを使っている限りにおいては、
  • VCCI自主規制値、FCC　ClassBの規制値はおそらくクリヤできています。（※３ｍ法を使用しての、認定されていない電波暗室内での測定ですから、公的な証明にならないことを承知しておいてください）
  • しかし、テレビ、ラジオのそばでの使用は、雑音、画面の乱れ等、障害を与える可能性があります。
  • 機器内部でも対策は施しておりますが、特にUSB BUSパワー（外部DCアダプター未使用時）に直接ケーブルを取り付けて
    （フェライトコア無しの状態）使用することは絶対避けてください。

４．コマンドステーション及びDCパワーユニット機能について

  • 電力消費の少ない車輌の場合には、USB BUSパワーのみで動作しますが、DCC電圧低下によりデコーダ側が異常動作する可能性があるので気をつけてください。


DccPgm2 installation

導入 （インストール） 更新2006/01/19

  • DP1（ハードウエア）、DccPgm2（専用ソフトウエア）の導入方法を説明します。

１． DP1の導入

  • DP1は、USB機器ですので、USBドライバの導入が必要ですが、製品添付のCDによるPlug＆Playにより簡単に導入できます。
  • まず、DP1をUSBケーブルでPCに接続します。
  • 以下のようなダイアログが開くので、FDを挿入して、”次へ”を選択します。

  • 以下の様に警告が出ますが、そのまま　”続行”　を選択して以下のようになると導入は完了です。

２． DｃｃPgm2の導入

  • DccPgm2の導入はインストーラの実行により行います。→ DccPgm2inst.exe


DccPgm2 チュートリアル

チュートリアル 更新2006/01/20

１． まず、DP1が、USBケーブルで、PCに確実に接続されていることを確認して、DccPgm1を起動すると以下のような画面になります。

２． 画面の右側のタブをクリックすることによって、

  • Programmer (プログラマー）

  • Command Station (コマンドステーション）

  • PWM Power Unit (PWM　パワーユニット）

の３種類の動作モードを決定することができます。


DccPgm2 プログラマー

チュートリアル （プログラマー） 更新2006/01/20

※デコーダをのCV設定を行う場合には、必ず車輌にインストールされている状態か、
もしくは、モータ等出力がつながれている状態でなければなりません。

デコーダ情報

デコーダプロフィールは、メモ領域です。ご自由に情報を書き込んでください。

”更新”ボタンを押せば、データは保存されます。

ＣＶデータ保存

 メニューの"File/Save"かもしくは、メニューICONのフロッピーのICONをクリックするとＣＶ一覧表のデータを、保存することが出来ます。

また、"File/Save As"を選択した場合には、CV一覧データを別名で外部フォルダー等に出力することが可能です。

ＣＶ値のコピーペースト

  • ＣＶ一覧を選択（複数行化）して、右クリック行う。
  • ポップアップメニューの "Copy"を選択でコピー完了
  • ペーストを行いたい、デコーダの一覧を表示。
  • 右クリックのポップアップメニューで"Paste"を選択して完了
  • Paste先に存在しない"CV"は無視されます。

  1. PGMTREE：プログラムツリーのナビゲーション

  2. CVLIST：デコーダの一覧表示、設定変更

  3. Speed Chart：車載デコーダのスピードテーブルのグラフィカル表示、設定変更

  4. User Folder：ユーザ定義フォルダ

  5. CV Config：CV情報の設定/デコーダ情報の作成

戻る


DccPgm2 プログラマー

プログラムツリーのナビゲーション 更新2006/01/20

左側の画面のツリーのアイテムをクリックすることにより、配下のフォルダの展開あるいはデコーダの一覧を展開します。デコーダアイテムは緑色で表現されます。デコーダアイテムをクリックしたときに右側の画面にＣＶ一覧が展開されます。

ＧＥＮＥＲＩＣテンプレート：

汎用デコーダのＣＶ一覧を管理します。保存は出来ませんが、デコーダを登録するときのテンプレートとして使用します。もちろんCV値のRead/Writeは可能です。

製造会社別フォルダー：

製造会社別の製品別デコーダの初期値を管理します。デコーダ情報の登録管理が自由に出来ます。

ユーザ定義フォルダー：

ユーザが自由にデコーダ個別情報を管理する目的で使用できます。フォルダーを自由に作成でき階層的に管理できます。製造会社別フォルダーからの、上方がコピーできます。

１．製造会社一覧のメンテナンス

  • ”マルチファンクションデコーダ”のフォルダを選択して右クリックするとメニュが開きます
  • "Edit Manufacturer List"を選択するとダイアログが開きます。
  • 右側のリストが登録されている会社で、選択する会社をダブルクリックするか。”使用する<<”ボタンをクリックすると左側の使用中リストに移動します。
  • フォルダに表示される順番を "上↑""下↓”ボタンをクリックして並べます。
  • "UPDATE"ボタンにより、プログラムツリーのフォルダが更新されます。
  • ツリーから会社を削除してもＤＩＳＫ上のデコーダ情報は削除されません。
  • アクセサリデコーダの会社一覧をメンテナンスするときは、”アクセサリデコーダ”を選択して右クリックします。

２．製造会社別デコーダ一覧のメンテナンス

  • 製造会社を選択して右クリックします。
  • "Edit Manufacturer Folder"を選択します。
  • フォルダ編集ダイアログが開きます。
  • ここでは、"Digitrax"を"デジトラックス"に変更してみました
  • この画面ではデコーダ一覧に関しては、表示の順番のみを”更新ボタン”により変更することが出来ます。

３．デコーダのメンテナンス

  • デコーダを選択して右クリックします。
  • "Edit Decoder"を選択します。
  • ”デコーダ編集”ダイアログが開きます。
  • この画面では、デコーダの表示名及びファイル名の修正を行うことが出来ます。
  • ファイル名以外のディレクトリパス及び拡張子(.ini)の変更で出来ません。

※”このデコーダを削除”ボタンをクリックすると、表示されているデコーダファイル自身も削除しますのでご注意ください。

４．デコーダ情報のコピー

  • デコーダアイテムを選択して、　コピー先のフォルダに”ＣＴＲＬキー”を押しながらドラッグします。

  • デコーダアイテムは、"User Folder"　配下ならびに”製造会社別フォルダ”にコピー可能です。

５．デコーダ情報のインポート

  • インポート先のフォルダを選択して、メニューの "File/ImportDecopder"を選択するか右クリックのポップアップメニューの "ImportDecoder"を選択します。
  • ファイル選択ダイアログが開きますので、デコーダ情報ファイル(***.ini)を指定してインポートします。
  • インポートは、ファイルエクスプローラで直接フォルダにドラッグ＆ドロップすることも可能です。
  • インポート先フォルダが、製造会社別フォルダの場合には、デコーダ形式（アクセサリ もしくは車載デコーダ）が同一の場合には、製造会社ＩＤが異なっていてもインポートされます。
  • インポート先のフォルダが、"マルチファンクションデコーダ”もしくは”アクセサリデコーダ”の場合には、デコーダ情報ファイルの、製造会社IDのデータをチェックしてインポートすべきフォルダを決定します。

ユーザ定義フォルダのメンテナンス

戻る


DccPgm2 CVLIST

チュートリアル （CVLIST） 更新2006/01/19

1.プログラミングモードの設定確認

DccPgm2では、CV一覧表示（CVスキャン）で３種類のCV読み出しモードを用意しています。

  1. Paged Mode:
    全てのデコーダでサポートしなければならない、プログラミングモードです。
  2. Direct Mode:
    比較的最近のデコーダでサポートされている、プログラミングモードで、Pagedモードより多少早いです。
  3. Direct Mode + bit mode (デフォルト)：
    最も、読み出し速度が速いモードで、1,2のモードに比べて約２０倍程度早く読み出すことができます。
    本来であれば、"Direct Mode"がサポートされていれば、このモードが有効なのですが、実際には
    サポートされていないデコーダも存在します。

2.一覧の表示

  • 下図のように"マルチファンクションデコーダ"をダブルクリックもしくは、"+"をクリックして開くと、先頭に"Generic"とあって、その下にDCCメーカーリストが表示されます。
  • DCCメーカーリストは、全て表示するとツリーが大きくなり、見づらくなるので、ごく一部だけ登録しています。
  • DCCメーカーリストは、必要なメーカのみ表示非表示が可能です。
  • ここでは、SNJPNメーカーフォルダをダブルクリックもしくは、"+"をクリックして開くと、デコーダ一覧が表示されます。
  • "DE8"を選択すると、緑色のデコーダアイテムが選択状態となって赤色に変わり、右側のリストにＣＶ一覧が表示されます。

３． デコーダから、全CV値の一覧読み出し

スキャン実行中

※デコーダによって、サポートされていない”CV"は、CV値が"0"もしくは"255"と表示される場合があります。

４. CV値設定変更

  • 一覧表で設定変更したいCVを選択して、ダブルクリックをすると、"CV Read/Write"ダイアログが表示されます。

"Prev CV":CV一覧の選択を上に移動します。

"Next CV":CV一覧の選択を下に移動します。

  • このダイアログでは、Pagedモード、Directモードのほかに、OPSモードが利用できます。
  • ただし、OPSモードについては注意が必要です。OPSモードでは基本的に、WRITEのみ有効で、READ/VERIFYは
    サポートしません。
  • 理由は、OPSモードでの、READ/VERIFYはNMRAの規約で定義されていないからです。例えば、Digitrax社のデコーダは
    Transpndingの機能を使っています。
  • また、OPSモードを使うときには、デコーダのアドレスを指定しなければなりません。一覧表があらかじめSCAN済みで、"adrs"
    に正しいアドレスが表示されていない場合、手動でアドレスを指定して、OPSモードを使います。
  • "ExtAddress"とは、デコーダアドレスが１２７以下のときに２byteアドレスモードを使っている場合、明示的に指示しなければなりません。
  • 一般的には、１２７以下の場合は、1byteアドレスモードですが、NMRA規約上はどちらでも構いません。ただし、デコーダ、コマンドステーション双方でサポートされている必要があります。

5． CV一覧表で、選択したCV値のみの読み出し

  • 全CV値の読み出しは、デコーダによっては、長時間掛かる場合があり、また個別にダイアログを開くのは面倒なときに
    便利な機能です。
  • 下図のように、読み出したい、CVアイテムを複数選択して、全一覧読み出しと同様の手順を実行するだけです。

6. CV一覧表でＣＶ値のUpdate / OverWrite

  • Update:(変更書込み）
    スピードグラフでデータを変更した場合や、CV値のカット＆ペーストでペーストしたときに、その変更分の書込み処理をします。

  • OverWrite (上書き）
    現在一覧表示されているCV情報をすべてデコーダに書き出す。バックアップしているＣＶ値を書き戻すときに使用します。

7. デコーダアドレスの設定変更 (車載デコーダ)

  • デコーダアドレスに関係するCVは、CV1,CV17,CV18,CV19,CV29です。
  • 上記CVを個別に設定変更するのは面倒な作業となるので、DccPgm2では、アドレス専用の手順を用意しています。
  • 事前に、”GENERIC"等、一覧表を出しておきます。”SCAN"の必要はありません。
  • "読出し"ボタンを押すと、該当のCVが自動的に読取られて、計算します。
  • 図の例では、拡張アドレス(10001)であることを示しています。
  • アドレスの変更はアドレスモードとアドレス番号を入力して、"更新ボタン"を押します

8. デコーダアドレスの設定変更 (アクセサリデコーダ)

  • アクセサリデコーダアドレスに関係するCVは、CV513,CV521,CV541です
  • アクセサリデコーダは、正式には、CV513から始まるCV番号で構成されますが、コマンドステーションの制約等により一般的には、互換モードに設定されています。
  • 互換モードとは以下のようにCV番号を読み替える機能です。

    CV513 -> CV1
    CV514 -> CV2
  • 互換モードに設定されている場合には、逆に、CV513から始まる正式のCV番号ではアクセスできないのでご注意ください。
  • DccPgm2では、"読出し"ボタンを押下したときには、この互換モードの判定を行っていますが、判定に失敗することもあります。

  • Ｏｕｔｐｕｔアドレスモードとは、たとえば、4出力あるデコーダの各々の出力に連番でないアドレスを割り付ける機能のあるデコーダですが。この場合には、デコーダアドレスは1番目の出力のアドレスをさします。
  • "Ｏｕｔｐｕｔアドレスモードは、CV541にて決定され、このモードの変更は一般的には不可能です。

９．ＣＶ一覧の印刷

CV一覧が表示されている状態で、印刷することが出来ます。以下はプレビュー画面です。


DccPgm2 SpeedChart

チュートリアル （Speed Chart） 更新2006/01/19

1． デコーダから、全CV値の一覧読み出し

スキャン実行中

  • "Speed Chart "タブをクリックするとスピードチャート画面に切り替わります
  • ”ＳＣＮ”メニューをクリックするとCV読出しが始まり、"CANCEL"で中断できます。
  • グラフがリアルタイムに更新されます。
  • "28 Speed Step Mode"の"Enable"のチェックが"OFF"になっていますがこれは、このデコーダでスピードテーブルが無効になっていることをあらわします。

2. グラフ直接操作による、CV値設定変更

  • グラフの、四角い箱を、マウスでつかんで曲線を調整します。
  • 変更したCVはグラフ上で赤くなります
  • メニューの"UPD"クリックで修正分の書込みを行います。

  • スピードテーブルを有効にするには"28 Speed Step Mode"の"Enable"のチェックを"on"して"Update"ボタンをクリックする必要があります。

3. 個別CVの設定変更

CVLISTと同様の手順です。

4． 一覧表で、選択したCV値のみの読み出し

CVLISTと同様の手順です。

５．スピードテーブルの印刷

スピードテーブルが表示されている状態で、印刷することが出来ます。以下はプレビュー画面です。


DccPgm2 ユーザフォルダ

ユーザ定義フォルダ 更新2006/01/20

１．ユーザ定義フォルダの追加

  • ユーザフォルダを選択して"Add User Folder"メニューを選択します
  • 配下にフォルダーが自動作成されます。
  • このあと、適当な名前に修正することが出来ます。

２．ユーザ定義フォルダ編集

  • ユーザフォルダを選択して"Edit User Folder"メニューを選択します。
  • ここでは、"F003"というフォルダ名を”一時作成用”というフォルダ名に変更しています。
  • ”このフォルダを削除”ボタンをクリックすると、このフォルダ自身と配下の子フォルダを含めて削除します。

※フォルダ削除はデコーダ定義ファイルの削除は行いません。

３．ユーザ定義フォルダの移動

  • ユーザフォルダを選択して、移動先のフォルダにドラッグします。

  • ユーザ定義フォルダは、"User Folder"　配下のみで移動可能です。

４.デコーダ情報の移動

  • デコーダアイテムを選択して、移動先のフォルダにドラッグします。

  • ユーザ定義フォルダは、"User Folder"　配下のみで移動可能です。

５.デコーダ情報のコピー

  • デコーダアイテムを選択して、　コピー先のフォルダに”ＣＴＲＬキー”を押しながらドラッグします。

  • デコーダアイテムは、"User Folder"　配下ならびに”製造会社別フォルダ”にコピー可能です。


DccPgm2 CV一覧設定

CV情報の設定 /デコーダ情報の作成 更新2006/01/20

１．デコーダ情報の作成

  • デコーダ情報の作成は既存のデコーダ情報のコピーもしくは "GENERIC"データの任意のフォルダへのコピーにより作成します。
  • デコーダ情報のエントリ作成後、デコーダメンテナンスにより、表示名、ファイル名を変更することも可能です。

２．ＣＶ情報の修正

  • ＣＶ情報をを選択して右クリックをして、ポップアップメニューをだし、"Edit CV"を選択します。
  • CV編集ダイアログが開きます。
  • "PrevCV<<"で上は、">>NextCV"で下に選択を移動させることが出来ます。
  • 説明、詳細の編集を行い”更新”で完了します。
  • ＣＶ番号を変更して"Enter"キーを押すと、ＣＶ追加モードになります。説明、詳細の編集行って、”ＣＶを追加ボタン”で完了します。
  • "このCVを削除"削除されます。


DccPgm2 簡易コマンドステーション

チュートリアル （コマンドステーション） 更新2006/01/20

  • "主電源 入"を押すことによて、ボタンが橙色に変わります。
  • 緊急の場合には、"非常”ボタンを押すと、赤いボタンが点滅して、緊急停止信号が全デコーダに対して発報されます。
  • "復帰"ボタンにより復帰します。
  • 画面では、"試運転”列車が選択されていて、アドレスは３に設定されています。
  • 画面左側の、タブもしくは、列車一覧の列車の選択を切り替えることにより、運転する列車を変更することが出来ます。
  • 列車アドレスは、直接変更できます。
  • アクセサリ制御は、1-999までのSWを一覧表から直接出力することが出来ます。

列車情報の編集

  • 列車を一覧で選択して、ダブルクリックするか、”列車設定”ボタンをクリックしてダイアログを開きます。
  • 列車番号、ＤＣＣアドレスを入力して、"列車番号 設定”ボタン　、”DCCアドレス設定”ボタンを各々クリックして設定します。
  • 列車を追加するときには、列車番号、ＤＣＣアドレスを設定して、"列車追加"ボタンをクリックします。
    ※列車数は試運転を含めて最大５列車までです。
    ※試運転は一時的にアドレス変更、削除は可能ですが、再起動したときには強制的に設定されます。
  • "列車削除"ボタンにより列車は削除されます。
    ※このとき列車は停止状態でないとそのまま走行し続けるので注意してください


DccPgm2 DCパワーユニット

チュートリアル （DCパワーユニット） 更新2006/01/20

  • PWM周波数は約30Hzから約800Hzまで調節できます。
  • PWMの周波数が低いためコアレスモータには適しません.


DccPgm1 注意

使用上の注意とトラブル対処 更新2003/07/05

１．取り扱い

  • DP1において、USBケーブルの抜き差し、ならびに、DCアダプタの取り外しの際は必ず、DccPgm1を終了したで、
    行ってください、ハングアップ等のトラブルの原因となります。
  • ハングアップしたりアプリケーションが異常終了した場合には、DccPgm1を終了の上、USBケーブルの再接続を行ってください。DP１にはリセットボタンはついておりません。

２．USB電力について

  • DP1は、DCC信号を送出するために、最大500mAの電力供給を要求します。
  • 特に、瞬間的に最大電流まで達するために、電源の弱いPCを使用している場合、あるいは
  • USBハブを経由して使用している場合には、急激な電力要求に耐えられずに、パソコンと共にハングアップするケースがあります。
  • 逆に、デコーダ設定時に、最大電流を要求するのは極わずかな時間(10mSec以内）なので、明らかに電源能力オーバーなのに問題なく動作することもありますが、上記のことを十分留意してご使用ください。
  • 十分に容量のある、外部電源を接続している場合でも、DCCに接続しているモータからのサージ電流により、ハングアップするケースもまれにあります。
  • 内部的には、電源のフィルタリングとサージ対策はしておりますが、完全に絶縁しているわけではないので注意してください。

３．電磁波対策について

  • DP1はUSBを使ったコンピュータ機器ですので、強い電磁波（ADSLモデム程度）が内部で発生しています。
  • DP1専用ケーブルに取り付けられている、”フェライトコア”と呼ばれるものを使っている限りにおいては、
  • VCCI自主規制値、FCC　ClassBの規制値はおそらくクリヤできています。（※３ｍ法を使用しての、認定されていない電波暗室内での測定ですから、公的な証明にならないことを承知しておいてください）
  • しかし、テレビ、ラジオのそばでの使用は、雑音、画面の乱れ等、障害を与える可能性があります。
  • 機器内部でも対策は施しておりますが、特にUSB BUSパワー（外部DCアダプター未使用時）に直接ケーブルを取り付けて
    （フェライトコア無しの状態）使用することは絶対避けてください。

４．コマンドステーション及びDCパワーユニット機能について

  • 電力消費の少ない車輌の場合には、USB BUSパワーのみで動作しますが、DCC電圧低下によりデコーダ側が異常動作する可能性があるので気をつけてください。

戻る


DccPgm1 設定ファイル

設定ファイル 更新2003/07/05

1. ファイル構成

  • DccPgm1では、Windowsのレジストリはほとんど利用せず、基本的に ”ini” ファイルと呼ばれる旧来からの設定ファイルを使用しています。"ini"ファイルの利点は、編集及びコピーが簡単なことです。
  • 現行バージョンでは、直接ファイルを編集することによって設定してください。
  • 各エントリーとも一部抜粋して、仕様を公開します。
  • 設定ファイルの構成を以下に示します。

2. DccPgm1.ini

エントリ | 設定値説明 | 詳細説明
[GLOBAL]
LANG | "JP"もしくはその他 | ”JP”で一部日本語化表示します
LOG | ”ON" or ”OFF" | ”ON"でログファイルが作成されて、出力されます。
[Manufacturer list of multi-function decoder]
メーカ表示名=メーカID メーカ表示名=メーカID ・・・・・ メーカ表示名=メーカID
[Manufacturer list of accesoory decoder]
メーカ表示名=メーカID メーカ表示名=メーカID ・・・・・・ メーカ表示名=メーカID
※”メーカ表示名”は、DccPgm1の左側のツリーに表示される内容で、順番をここで変更したり新規に追加したり出来ます。ただし、"MFnn.ini" (nn=メーカID)ファイルが同じフォルダ内に存在していなければなりません。

3. MFnn.ini

  • このファイルは、メーカID毎に必要な設定ファイルで、デコーダのリストを管理します。
エントリ | 詳細説明
[multi-function Decoder Entry]
デコーダ表示名=設定ファイル名 デコーダ表示名=設定ファイル名 ・・・・・・ デコーダ表示名=設定ファイル名 |
[accessory Decoder Entry]
デコーダ表示名=設定ファイル名 デコーダ表示名=設定ファイル名 ・・・・・・ デコーダ表示名=設定ファイル名
※”デコーダ表示名”は、DccPgm1の左側のツリーの所属するメーカ名の下に表示される内容で、順番をここで変更したり新規に追加したり出来ます。ただし、設定ファイルが同じフォルダ内に存在していなければなりません。

3. XX.ini

  • このファイルは、デコーダ毎に必要な設定ファイルで、CV値のリストを管理します。
  • このファイルを参照することにより、デコーダの初期値等が参照及び変更ができます。
エントリ | 説明
[Profile] |  |
ProductName | 上図のように表示されるだけです
Desc
Note
DecoderType | 0 , 1 | 0=車載デコーダ,1=アクセサリデコーダ
[CV DESCRIPTION]
CVnn=表示名:詳細説明 CVnn=表示名:詳細説明 ・・・・・・ CVnn=表示名:詳細説明
※”表示名”と、詳細説明は、”:” （コロン）で、区切ります。ここで、設定した情報は、NMRAでの初期名称と入れ替えます
[CV Entry]
CVnn=CV値 CVnn=CV値 ・・・・・・ CVnn=CV値
※ここで、指定したCV情報のみが、一覧表にリストされます。

戻る


decoder cfg

デコーダ定義ファイル 更新2003/10/07

1.デコーダ定義ファイル

  • デコーダのCV値は、NMRAで定義されているCV番号のほかは、各メーカーによって自由に定義されています。このCV値の各々を、名称とともに簡略化して表示することにより、デコーダの設定がより簡単になります。

  • また、初期値を管理することによって、デコーダ自身に全CV値リセットの機能が装備されていなくても、全リセットが容易に可能となります。

  • この定義ファイルの仕様は公開していますので、各自、自由に作成編集すると良いでしょう

2.導入方法

  1. デコーダ設定ファイル(*.ini)を適当なディレクトリにダウンロードします。

  2. メニューから"File/Imoprt Decoder cfg"を選択します。

  3. ダウンロードしてきたディレクトリにある、該当ファイルを指定します。

  4. インポート完了しても、ツリーは自動更新しないので、一時的に,他のエントリを選択すると、正しく表示されます。
    →

  5. なお、既にデコーダエントリが導入されている場合は、処理を中断しますので、入れ替えたい時は、直接ファイルを上書きしても良いですし、"mf99.ini :Digitraxの場合は mf129.ini)" 中のエントリを削除すれば、再導入可能です。

  6. また、デコーダの表示順を変更したいときも、"mf99.ini"のエントリを編集すれば変更できます。


DccPgm1 詳細

概要、仕様

1. 概要

DccPgm1は、DP１と共に使用する、ソフトウエアです。

Windowsによる、GUIによって、今まで面倒であった、DCCデコーダの設定を飛躍的に簡単にします。

DirectMode + BitModeの利用により、全CV値の読み出しが、フル装備のデコーダでも、１分あまりで完了します。このモードを使っていない
システムでは、１０～２０倍、時間が余計に掛かります。

また、デコーダの設定と試験運転を同時に行うことにより、デコーダの能力を１００％引き出すことが可能です。

2. 仕様

項目 |  | 内容
CVプログラミング機能 |  | Paged Mode Direct Mode(bit mode含む) OPSモード
動作電圧 | BUSパワー時 | 5V 500mA
 | 外部電源 | 9-18V 定格1A （逆接続保護） 2.1mm センタープラス DCプラグ
出力 | BUSパワー時 | 約+-12V 100mA 出力遮断回路あり
 | 外部電源 | 9-18V 定格1A 出力遮断回路あり
USBインターフェース |  | USB1.1 BUS Power MAX 500mA
簡易コマンドステーション |  | 車載デコーダ 28,128ステップモード ファンクション 1-12 アクセサリーデコーダ対応 ※パケットを送るだけで、デコーダを管理する機能はありません。
簡易DCパワーユニット |  | PWM (30Hz-800Hz)
PCプラットホーム |  | Windows98/2000/XP
外形寸法 |  | 56*66*21mm
付属品 |  | 専用接続ケーブル フロッピーディスク（USBドライバ、ソフトウエア） ※USB接続ケーブル、１２V DCアダプタ（2.1mm センタープラス ）は別途ご用意ください


DccPgm1 Decoder Management Software

USB接続（BUSPOWER)デコーダプログラマ

簡易コマンドステーション

簡易PWM式DCパワーユニット

MANUAL v1.１　2003/10/07

概要、仕様

使用上の注意とトラブル対処

導入（インストレーション）

チュートリアル

デコーダ定義ファイル

設定ファイル

Nagasue System Design Office


DccPgm1 installation

導入 （インストール） 更新2003/07/05

  • DP1（ハードウエア）、DccPgm1（専用ソフトウエア）の導入方法を説明します。

１． DP1の導入

  • DP1は、USB機器ですので、USBドライバの導入が必要ですが、製品添付のFDによるPlug＆Playにより簡単に導入できます。
  • まず、DP1をUSBケーブルでPCに接続します。
  • 以下のようなダイアログが開くので、FDを挿入して、”次へ”を選択します。

  • 以下の様に警告が出ますが、そのまま　”続行”　を選択して以下のようになると導入は完了です。

２． DｃｃPgm1の導入

  • DccPgm1は、USBのドライバ以外は、単体で動作可能なソフトウエアです。ただし、設定情報の記憶と、
    デコーダのリストの為にいくつかの設定ファイルを使っています。
  • また、Helpファイルに関しては、"dccpgm1_helpj.chm"を"DccPgm1.exe"と同じフォルダに格納してください。
  • 初期設定ファイルも含めて、フロッピーディスクのフォルダ、”APLの中にあるので、それを適当なフォルダにコピーして使用してください。設定ファイルの詳細は別に説明します。


DccPgm1 チュートリアル

チュートリアル 更新2003/07/05

１． まず、DP1が、USBケーブルで、PCに確実に接続されていることを確認して、DccPgm1を起動すると以下のような画面になります。

２． 画面の左側のツリーもしくは、右側のタブをクリックすることによって、

  • Programmer (プログラマー）

  • Command Station (コマンドステーション）

  • PWM Power Unit (PWM　パワーユニット）

の３種類の動作モードを決定することができます。


DccPgm1 ACCCVLIST

チュートリアル （CVLIST ACCESSORY） 更新2003/07/05

1.一覧の表示

  • 下図のように"Accessory Decoder"を開くと、先頭に"Generic"とあって、その下にDCCメーカーリストが表示されます。

２． デコーダから、全CV値の一覧読み出し

  • ツールバーの"SCN"で読み出しを行います。

3. CV値設定変更

  • 一覧表で設定変更したいCVを選択して、ダブルクリックをすると、"CV Read/Write"ダイアログが表示されます。

4． 一覧表で、選択したCV値のみの読み出し

  • 読み出したい、CVアイテムを複数選択して、全一覧読み出しと同様の手順を実行するだけです。

5. デコーダアドレスの設定変更（アドレス読み出し）

  • デコーダアドレスに関係するCVは、CV513,CV521,CV541です。
  • 手元にあるデコーダにアドレスを設定変更するのは面倒な作業となるので、DccPgm1では、アドレス専用の手順を用意しています。
  • 事前に、”GENERIC"等、一覧表を出しておきます。”SCAN"の必要はありません。
  • "READ"ボタンを押すと、該当のCVが自動的に読取られて、計算します。
  • 図の例では、DecoderAddressMode で アドレス(1)であることを示しています。SW番号は1-4までです。
  • ※OutputAddressモードのときは、アドレス=SW#です。つまり１チャンネルのデコーダであることを示します。

6. デコーダアドレスの設定変更（アドレス設定）

  • アドレスモードとアドレス番号を入力して、"UPDATE"ボタンを押すだけです。


DccPgm1 Command Station

チュートリアル 簡易コマンドステーション 更新2003/07/05

  • 簡易コマンドステーションは、通常のコマンドステーションと異なり、アクションをしたときに初めて、コントロールパケットをデコーダに送ります。
  • 通常は、アイドルパケットを送りつづけています。
  • 通常のコマンドステーションでは、コントロールパケットを繰り返し何度もデコーダに送りつづけるため、レールの汚れ等で”瞬停”が発生しても、デコーダは何事も無かったように作動することが可能ですが、簡易コマンドステーションでは、”瞬停”が発生すると、デコーダは再起動した状態で止まってしまいます。
  • ”Repeat"をチェックすることにより、約１秒ごとに同じコントロールパケットを送ることができます。


DccPgm1 CVLIST

チュートリアル （CVLIST） 更新2003/07/05

1.プログラミングモードの設定確認

DccPgm1では、CV一覧表示（CVスキャン）で３種類のCV読み出しモードを用意しています。

  1. Paged Mode:
    全てのデコーダでサポートしなければならない、プログラミングモードです。
  2. Direct Mode:
    比較的最近のデコーダでサポートされている、プログラミングモードで、Pagedモードより多少早いです。
  3. Direct Mode + bit mode (デフォルト)：
    最も、読み出し速度が速いモードで、1,2のモードに比べて約２０倍程度早く読み出すことができます。
    本来であれば、"Direct Mode"がサポートされていれば、このモードが有効なのですが、実際には
    サポートされていないデコーダも存在します。

2.一覧の表示

  • 下図のように"Multifunction Decoder"を開くと、先頭に"Generic"とあって、その下にDCCメーカーリストが表示されます。
  • DCCメーカーリストは、全て表示するとツリーが大きくなり、見づらくなるので、ごく一部だけ登録しています。
  • メーカーフォルダを開いて、デコーダを選択することも可能ですが、ここでは”Generic(汎用)”デコーダとして表示させます。

３． デコーダから、全CV値の一覧読み出し

スキャン実行中

※デコーダによって、サポートされていない”CV"は、CV値が"0"もしくは"255"と表示される場合があります。

４. CV値設定変更

  • 一覧表で設定変更したいCVを選択して、ダブルクリックをすると、"CV Read/Write"ダイアログが表示されます。

  • このダイアログでは、Pagedモード、Directモードのほかに、OPSモードが利用できます。
  • ただし、OPSモードについては注意が必要です。OPSモードでは基本的に、WRITEのみ有効で、READ/VERIFYは
    サポートしません。
  • 理由は、OPSモードでの、READ/VERIFYはNMRAの規約で定義されていないからです。例えば、Digitrax社のデコーダは
    Transpndingの機能を使っています。
  • ただし、NGDCCデコーダだけは、NMRA規約外ですが、Pagedモード,Directモードと同様の仕組みを使っているので、DccPgm1での読み出しは可能です.
  • また、OPSモードを使うときには、デコーダのアドレスを指定しなければなりません。一覧表があらかじめSCAN済みで、"adrs"
    に正しいアドレスが表示されていない場合、手動でアドレスを指定して、OPSモードを使います。
  • "ExtAddress"とは、デコーダアドレスが１２７以下のときに２byteアドレスモードを使っている場合、明示的に指示しなければなりません。
  • ※一般的には、１２７以下の場合は、1byteアドレスモードですが、NMRA規約上はどちらでも構いません。ただし、デコーダ、コマンドステーション双方でサポートされている必要があります。

5． 一覧表で、選択したCV値のみの読み出し

  • 全CV値の読み出しは、デコーダによっては、長時間掛かる場合があり、また個別にダイアログを開くのは面倒なときに
    便利な機能です。
  • 下図のように、読み出したい、CVアイテムを複数選択して、全一覧読み出しと同様の手順を実行するだけです。

6. デコーダアドレスの設定変更（アドレス読み出し）

  • デコーダアドレスに関係するCVは、CV1,CV17,CV18,CV19,CV29です。
  • 手元にあるデコーダにアドレスを設定変更するのは面倒な作業となるので、DccPgm1では、アドレス専用の手順を用意しています。
  • 事前に、”GENERIC"等、一覧表を出しておきます。”SCAN"の必要はありません。
  • "READ"ボタンを押すと、該当のCVが自動的に読取られて、計算します。
  • 図の例では、拡張アドレス(10001)であることを示しています。

6. デコーダアドレスの設定変更（アドレス設定）

  • アドレスモードとアドレス番号を入力して、"UPDATE"ボタンを押すだけです。


DccPgm1 DC Power Unit

チュートリアル DC Power Unit 更新2003/07/05

  • PWMは約30Hzから約800Hzまで調節できます。
  • PWMの周波数が低いためコアレスモータには適しません.


DccPgm1 プログラマー

チュートリアル （プログラマー） 更新2003/07/05

※デコーダをのCV設定を行う場合には、必ず車輌にインストールされている状態か、
もしくは、モータ等出力がつながれている状態でなければなりません。

DｃｃPgm1でのプログラマーでは、３つのモードを用意しています。

  1. CVLIST：車載デコーダの一覧表示、設定変更

  2. Speed Chart：車載デコーダのスピードステップのグラフィカル表示、設定変更

  3. CVLIST ACCESSORY：アクセサリデコーダの一覧表示、設定変更

戻る


DccPgm1 SpeedChart

チュートリアル （Speed Chart） 更新2003/07/05

1． デコーダから、全CV値の一覧読み出し

スキャン実行中

2. グラフ直接操作による、CV値設定変更

  • グラフの、四角い箱を、マウスでつかんで曲線を調整します。

3. 個別CVの設定変更

CVLISTと同様の手順です。

4． 一覧表で、選択したCV値のみの読み出し

CVLISTと同様の手順です。